Ultrasound precision small room

Frequent questions asked online, offline, in forums are answered here
Post Reply
Posts: 1
Joined: Mon May 18, 2020 2:41 pm

Ultrasound precision small room

Post by ark »

I am currently working on my college project and my goal is to correctly set and use a GPS indoor system that will be later used for a small drone. Since we are still in lockdown and my university is closed, I am trying to make work the "Starter Set NIA-SmallDrone" at home in my room (the sizeof the room is 3m x 5m). But i have been encountering a few issues.

The problem at the moment is that once I wake the system, the hedgehog doesn't update its coordinates as you can see in the picture below.

Here are the steps that i took to get started (i've been struggling on this for about three weeks now, so these steps I've repeated them a few times):

- I am currently running the v6.120 NIA firmware on modem and all beacons. The dashboard that i'm using is installed on Windows 10 (the new dashboard doesn't load on Centos8, when i plug the modem it says "undefined symbol: device_type_is_supermodem". I didn't have this problem on the older version).

- Before starting the experiment, i've turned off all beacons and charged them for about an hour.

- Then i've turned on the switches, erased all maps from dashboard and started linking up mini-RX beacons first.

- When all mini-RX beacons were connected, I've manually loaded coordinates for each beacon (<x,y,z> coordinates measured with a laser distance meter), then i froze submap and average distances (average distances were automatically loaded and I had close values to those that I measured).

- Then i checked that for every mini-RX beacon i have a radio signal that is between -20dBm and -70dBm and indeed the signal had an average of -55dBm.

- At this point everything was fine for me, so I froze the map and woke the hedgehog.

So when hedgehog wakes up it just stays at coordinates 0,0,0 represented by an orange filled circle. I've checked on the oscilloscope if I got any read from mini-RX beacons and it seems that the hedgehog is properly detected since the red line trigger is positioned at about the same distance between the beacon and the hedge. So it seems strange that on the dashboard i get neither a correct measurement nor an activity of the hedgehog when i move it.

I've tried to turn on just one mini-RX beacon and see if at least the one detects properly the hedgehog and it appears that in 1D mode it kinda works : only if i get the hedge close enough to the beacon (below 40/50cm), the dashboard starts to detect hedge's movement and it updates its coordinates on the screen (erratically, when i move the hedge a few cm back and forth, it displays movements of various meters on screen) on one dimension.

So by now I think that perhaps the issue is with the ultrasound detection. So in order to make work the system at least in 2D i've tried to reduce the noise captured by beacons. I've set the RX amplifier on beacons to 0 and set number of periods on hedge to 1, when i check on the oscillo if i still get a proper read it seems to work fine, but still on the dashboard nothing happens.

Is there anything else that I've forgot to do or maybe is my room too small that I need to enhance some settings?

Hedgehog ultrasound settings :

mini-RX ultrasound settings :

If you need more information about some settings don't hesitate to ask.

Thanks guys, hope to hear from you soon!

Posts: 367
Joined: Sat Feb 06, 2016 4:03 pm

Re: Ultrasound precision small room

Post by smoker77 »


On the screenshot I see you have 'Number of periods' 1 for the mobile beacon.
This may be too weak ultrasonic emission even for so small distances.
Please try 5 or 50 periods.

If this will not help, please share file generated by 'Save map' button and screenshots of the embedded oscilloscope.

As for error message from dashboard in Linux - it looks like dashboard executable file was updated, but library file 'libdashapi.so' was not updated in 'usr/local/lib' directory. Please try to update.

Post Reply