Map disconnected in linux dashboard after running the ros node

Frequent questions asked online, offline, in forums are answered here
Post Reply
Vivek Harkhani
Posts: 2
Joined: Tue Mar 29, 2022 2:36 pm

Map disconnected in linux dashboard after running the ros node

Post by Vivek Harkhani »

Hi, I am using super beacon and modem HW v5.1 in linux dashboard Version-7.040.
First I'll explain the setup:
1. I am using NI architecture for the lab which is about 15 m* 5m, with stationary beacons mounted at same height of 2.3 meter.
2. As suggested to increase the update date I have turned off the Real_time Player, for NIA window of averaging to 0 and Distance filter to 0.
3. The table shows no red to yellow elements which means the distance between the stationary beacons is measured correctly.
4. I have set the location update rate to initially at 8 hz and the update rate where fluctuating and then I tried at 12, 16,16+ even then the update rate fluctuates between 1 and 5 hz.
5. I froze the map and then I started ros node and the output on the screen is at frequency of 0.1 Hz and rostopic hz /hedge_pos_a is publishing at rate of 0.1 to 0.2 Hz
6. After I start the ros node, I observed that the map in the dashboard is disconnected and modem as well. After 5-10 seconds I observe that modem starts connecting once again and map is loaded and this cycle is repeating.

It would be great help if anyone could pinpoint where I am going wrong in 4,5 and 6th step

Vivek Harkhani
Posts: 2
Joined: Tue Mar 29, 2022 2:36 pm

Re: Map disconnected in linux dashboard after running the ros node

Post by Vivek Harkhani »

Sorry I forgot to give a link for screenshot of the above given post
1. This screenshot shows the normal behavior of the dashboard https://postimg.cc/K1sq6NHs
2. This screenshot shows the output of the ros node which show irregularity in several seconds in timestamp https://postimg.cc/fSjjcJRY
Last edited by Vivek Harkhani on Fri Apr 01, 2022 2:03 pm, edited 1 time in total.

smoker77
Posts: 379
Joined: Sat Feb 06, 2016 4:03 pm

Re: Map disconnected in linux dashboard after running the ros node

Post by smoker77 »

Hello

Sorry for the delayed reply.

Dashboard and ROS node can't be used for communication with the modem at the same time.
They use same serial port for communication and they are conflicting.

You can close the dashboard when work with ROS. Dashboard is not required for system work when map is already built.
Or you can connect modem to PC with dashboard and connect mobile beacon to the PC with ROS (it can be even same PC).
Modem will communicate with dashboard and ROS node will get data from mobile beacon without conflicts

Post Reply