Distance between paired beacons is not accurate

Frequent questions asked online, offline, in forums are answered here
Post Reply
fusion5
Posts: 1
Joined: Tue Mar 09, 2021 6:47 am

Distance between paired beacons is not accurate

Post by fusion5 »

Hi, I have a set of 4 stationary super beacons and 2 mobile super beacons on a robot. I have verified that the 2 mobile super beacons independently track reasonably well. When I mount them on the robot and look at the positions (prior to pairing) in the dashboard, I can see that the difference in position approximately matches the distance between the beacons (0.57m).

However, once I pair the beacons and enter in the correct data (paired id, which side, and distance between pair), I can see the beacons on the dashboard visibly jump apart to now be about 0.9m apart, which is not correct. This incorrect separation distance is maintained even as I drive the robot around, however, apart from the incorrect distance, the tracking looks reasonable. If I unpair the beacons, they jump back to be the correct distance apart. I re-read through the manual that explains the setup for paired beacons and I believe I have done everything correctly. I also reconfirmed the distance between the beacons and it is most definitely 0.57m, which is exactly what I entered (but in cm as requested by the field) into the paired beacons section.

Is this expected behavior? Or is there something I am doing wrong here? Thanks.

smoker77
Posts: 367
Joined: Sat Feb 06, 2016 4:03 pm

Re: Distance between paired beacons is not accurate

Post by smoker77 »

Hello,

Do you mean distance between beacons from their coordinates streamed out from the beacons or distance between beacons in the dashboard view?
In the dashboard view distance between paired beacons can differ from real distance, because dashboard needs to draw paired beacons picture with line between beacons and the heading arrow between the beacons. So the drawn distance between beacons can be higher than real, it is normal.

Post Reply