hedgehog and rasberry pi 3 connection problem

Frequent questions asked online, offline, in forums are answered here
Post Reply
darren
Posts: 1
Joined: Mon Mar 16, 2020 9:03 am

hedgehog and rasberry pi 3 connection problem

Post by darren »

hello?

I have a Starter Set HW v4.9-NIA.
(https://marvelmind.com/product/starter-set-hw-v4-9/)

I connected the hedgehog to the raspberry pi 3 , but it failed.

If there is nothing connected to the hedgehog, the hedgehog will work normally.

If USB or UART is connected to the hedgehog, it does not work properly.

Symptoms include:

The position value is not updated when the hedgehog moves away.

If the USB (or UART) connection is lost again in that state, the hedgehog's position value is updated.

In the near position (about 30cm), the position value of the hedgehog is updated regardless of the connection.

I used only two pin (USART2_TX and GND PIN.)

How can I solve it?
Attachments
beacon HW 4.9 external interface.png

smoker77
Posts: 322
Joined: Sat Feb 06, 2016 4:03 pm

Re: hedgehog and rasberry pi 3 connection problem

Post by smoker77 »

Hello,

Do you have a tracking in dashboard when hedgehog stops transmitting data?
Please check RSSI (radio signal strength) value of the hedgehog in dashboard when it works and when it moves away and stops working.
Maybe radio signal is too strong or too weak. Normal RSSI is approximately between -25 and -80 dBm
Connection of UART wires can increase RSSI because these wires work as additional antenna

Post Reply