System reliability inquiry

Frequent questions asked online, offline, in forums are answered here
Post Reply
sethjones348
Posts: 2
Joined: Fri Oct 18, 2019 1:44 am

System reliability inquiry

Post by sethjones348 »

I am reaching out to seek some insight into how we can make our system more reliable. I have included tests that we have done to test the reliability of our system with different combinations of beacon configurations and parameters, etc. Overall, the system has functioned with varying degrees of success. However, there are still some fringe cases where we are experiencing unreliability. We would appreciate some help in diagnosing our issues.
Layout
This is the current setup for our 50 x 50 ft testing area. As can be seen, the setup is more of a rectangular shape, with a beacon backed into the corner of the warehouse.
Image

The heights of each beacon are around 1.85 m. Cardboard has also been added to reduce ultrasonic multipathing. All of the beacons are on tripods, because mounting directly to the wall seemed to affect the RF signal integrity for our building. We monitored the ultrasonic signals with the oscilloscope on dashboard, but did not know how to interpret the information.

Our setup includes a rover with two mobile beacons in a paired configuration sitting about 0.25m off of the ground.

The following is a test that was done with this main setup. Beacon 1 on the dashboard map corresponds to the beacon in the far corner of the building.

Image

The position error is not predictable, as seen above. We created submaps, as can be seen for beacons 1&4 and beacons 2&3.

We tried another configuration where all 4 beacons were positioned along the sides of the test area, instead of the corners.

Image

With this configuration we did not see any less error; however, the areas of failure were more concentrated towards the corner.

Image

Hardware
• Stationary beacons (beacons 1-4): HW v4.9
• Left hedge (hedge 10): HW v4.9
• Right hedge (hedge 11): HW v4.9-IMU
Firmware
• All beacons: SW v6.160
• Modem: SW v6.160
• Dashboard: SW v6.160

Parameter config
We have all of the parameters for the stationary beacons at the default. However, for the pair of hedges, hedge 11 (pink) has an IMU. We thought perhaps the IMU would help the overall reliability. The IMU can be seen as enabled below with some other general settings as well as ultrasonic settings for hedge 11.

Hedge11 settings

Image

Hedge11 ultrasonic settings

Image

Questions we have:
1. What is your suggested optimal placement for the beacons?
2. How do you use the oscilloscope to troubleshoot issues and what settings do you adjust during troubleshooting?
3. How can we eliminate the positioning error?

User avatar
admin
Site Admin
Posts: 305
Joined: Tue Jan 26, 2016 7:06 pm
Contact:

Re: System reliability inquiry

Post by admin »

Very quick response:
- You have built 2 2D submaps. But 2D submap assumes only one semi-plane - see the "nose" showing the direction. But you seem to go on the opposite side of the plane. You can't do that
- Was it TDMA configuration? IA or NIA?
- If you have just an open space, basic 2D submap would easily cover your territory. But make sure, that you don't cross the line connecting beacons

sethjones348
Posts: 2
Joined: Fri Oct 18, 2019 1:44 am

Re: System reliability inquiry

Post by sethjones348 »

Hi, thank you for your response.

We are using NIA.

Could you attempt to answer our specific questions? For the "diamond" configuration we were crossing the plane of the submaps, yes, but for the other configuration we were not crossing that plane and still experiencing unreliability.

Do you have any suggestions on the placement of our beacons within our shop?

How do we utilize the oscilloscope to figure out what our problem is and what settings do we adjust for troubleshooting?

Do you have any insight into how we can eliminate the positioning error?

Post Reply