Installing Marvelmind ROS package - Error: package 'marvelmind_nav' not found

Frequent questions asked online, offline, in forums are answered here
Elmik
Posts: 2
Joined: Fri Aug 09, 2019 2:47 pm

Installing Marvelmind ROS package - Error: package 'marvelmind_nav' not found

Postby Elmik » Fri Aug 09, 2019 2:55 pm

Hello, everyone!

I have problem with installing Marvelmind ROS Package. I follow these instruction (https://marvelmind.com/pics/marvelmind_ ... 09_11a.pdf) but after executing command:
$ rosrun marvelmind_nav hedge_rcv_bin
I get this error:
[rospack] Error: package 'marvelmind_nav' not found
What could possibly go wrong?

However, I have doubts about copying downloaded sources from the repository into the ~/catkin_ws/marvelmind_nav/. What exactly should be in ~/catkin_ws/marvelmind_nav/?
After executing command
$ ls -a ~/catkin_ws/marvelmind_nav
I get
. CHANGELOG.rst .directory include package.xml
.. CMakeLists.txt .hgtags msg src

Thank you in advance for your help!

Elmik
Posts: 2
Joined: Fri Aug 09, 2019 2:47 pm

Re: Installing Marvelmind ROS package - Error: package 'marvelmind_nav' not found

Postby Elmik » Mon Aug 12, 2019 10:46 am

I've found solution to my problem.

When you are this point (while you're following instruction - https://marvelmind.com/pics/marvelmind_ ... 09_11a.pdf):

Then create the directory for the package by executing commands in the terminal:
$ cd ~/catkin_ws/
$ mkdir marvelmind_nav
Then copy downloaded sources from the repository into the created directory.

You don't have to make 'marvelmind_nav' directory. Go to 'src' directory in 'catkin_ws':

$ cd ~/catkin_ws/src/

And here clone repository from github.

Then go back to catkin_ws:

$ cd ~/catkin_ws

And execute command:

$ catkin_make

After that I can find marvelmind_nav package nad communicate with Marvelmind devices using ROS.

smoker77
Posts: 239
Joined: Sat Feb 06, 2016 4:03 pm

Re: Installing Marvelmind ROS package - Error: package 'marvelmind_nav' not found

Postby smoker77 » Sat Aug 17, 2019 6:18 pm

Hello Elmik,

Thank you very much for the feedback.
I just checked and found that building of the package from source was skipped in the manual.
Your solution is correct.
The corrected manual is here:
https://drive.google.com/open?id=1jb129 ... RvPBFuypaW
We will publish the updated version on our site soon.


Return to “FAQ”

Who is online

Users browsing this forum: Bing [Bot] and 4 guests