Page 1 of 1

Uploading new Firmware to HW4.9 Starter Set fails

Posted: Thu Apr 04, 2019 8:37 pm
by DKluener
my organization recently purchased your Starter Set HW v4.9 433mhz for the European market and I unsuccessfully tried to flash the newest software to the beacons and was asking myself what my mistake was.
I followed your instructions for setting up the system precisely and:
1. Installed the newest Software for Ubuntu 16.04 LTS and followed your installation manual provided with the software.
2. Then I charged all the devices for about 4 hours.
3. Then I flashed the modem firmware to the modem, which worked flawlessly and after the upload was completed and the warning not to disconnect the device had disappeared, I disconnected the modem from the pc.
4. I selected upload software again and selected the newest software version for the beacon (Software_nia/beacon_hw49_nia/2019_03_13_beacon_hw49_sw6_080_433_7c66ffd.hex).
5. I then set the dip switches according to your manual entry on the first beacon and connected the first beacon to the pc. It was recognised by the software (and listed under a beacon name in the lower left corner) and was listed with old software (in the upper right corner, Software version 5.9 or something, if I recall correctly).
6. I then clicked upload firmware and it started uploading, but failed quickly with a message that read something like: "uploading firmware execution failed".
And I tried this with two of our beacons and on two different ubuntu machine and it recognised the beacons every time, but the upload also failed every time. So now I am unsure how to continue.
Thank you for your help.

Re: Uploading new Firmware to HW4.9 Starter Set fails

Posted: Mon Apr 15, 2019 7:16 pm
by DKluener
We were able to solve the problem on our own. Our solution was quite simple: We switched to a Windows PC and were able to flash all the beacons successfully.

Re: Uploading new Firmware to HW4.9 Starter Set fails

Posted: Wed Apr 17, 2019 3:09 pm
by smoker77
Thank you for the information about the issue and workaround.
Yes, current Linux version of dashboard (v6.08) can fail updating firmware from some older versions.
We will fix this issue in next software update.
Before this, please use Windows version of dashboard for updating software if Linux version fails in your case.