ROS-Hedgehog Interface Issues

Frequent questions asked online, offline, in forums are answered here
gebotics
Posts: 4
Joined: Mon Nov 26, 2018 10:32 pm

ROS-Hedgehog Interface Issues

Postby gebotics » Tue Nov 27, 2018 6:04 pm

I'm trying to gather data in ROS from the hedgehog and am not getting any data. Here's what's happening:
I have the map of beacons and such set up on a Windows computer with the modem plugged in there. Then I have a Linux machine with the hedgehog plugged in via USB.

On the Linux machine, I have roscore running, and all the documents/scripts associated with ROS and Marvelminds downloaded. Then I follow the directions found at: https://marvelmind.com/pics/marvelmind_ ... 09_11a.pdf.
I run:
$ source devel/setup.bash
find the serial port used (/dev/ttyACM0)
then run:
$ rosrun marvelmind_nav hedge_rcv_bin

It says that it has opened the serial port with baudrate 9600, and then nothing happens. According to the document, position data from the hedgehog should show up, but it's not there.

So, I tried running rosrun marvelmind_nav subscriber_test; and again nothing happens.

When I echo /hedge_pos, it gives me nothing.
I suspect that no data is being sent from the hedgehog, but I don't know why, I have tried two different hedgehogs with the same results.

Any idea what to try next?

Any help is appreciated.

Return to “FAQ”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest