Search found 16 matches

by zlite
Mon Nov 26, 2018 10:01 pm
Forum: FAQ
Topic: PX4 users?
Replies: 7
Views: 4524

Re: PX4 users?

I'm a PX4 user as well and interested in this. However PX4 does not currently have a Rover build, so it should only be used for multicopters for now. (Rovers will be supported in the future)
by zlite
Thu Nov 22, 2018 8:21 pm
Forum: FAQ
Topic: Marvelmind python does not get location data on raspberry pi 3
Replies: 5
Views: 2580

Re: Marvelmind python does not get location data on raspberry pi 3

Update. I finally got it working (at least for now), with some help from the Marvelmind team. It turns out that if you have the "power save function" enabled in the modem, it can disable the USB in the hedgehog.

So disable it and see if that fixes the problem
by zlite
Mon Nov 19, 2018 11:29 pm
Forum: FAQ
Topic: Marvelmind python does not get location data on raspberry pi 3
Replies: 5
Views: 2580

Re: Marvelmind python does not get location data on raspberry pi 3

BTW, as a work-around until they fix this, you can use the Marvemind UART pins and an Adafruit serial-to-USB adapter, which will show up at ttyUSB0 and works fine.

https://www.adafruit.com/product/954
by zlite
Mon Nov 19, 2018 9:54 pm
Forum: FAQ
Topic: Marvelmind python does not get location data on raspberry pi 3
Replies: 5
Views: 2580

Re: Marvelmind python does not get location data on raspberry pi 3

I'm seeing the same problem since the most recent firmware update, and I think it has something to do with the USB interface in the Marvelmind beacons. When you plug them into the RaspberryPi, they should show up in /dev as ttyACM0, like other devices, but they don't. I've asked the Marvelmind team ...
by zlite
Wed Nov 14, 2018 12:08 am
Forum: FAQ
Topic: New firmware update broke Python library :-(
Replies: 1
Views: 1073

New firmware update broke Python library :-(

It looks like the 5.93 firmware update, which changed the protocol, has broken the Python library, and I can no longer get data via USB in Python. Is there a plan to fix this soon?

https://marvelmind.com/pics/marvelmind_ ... _08_28.pdf
by zlite
Sat Nov 03, 2018 10:55 pm
Forum: FAQ
Topic: Latency
Replies: 3
Views: 1744

Re: Latency

One thing that seems to help is to set "Limitation Distances" to Auto in the submap settings
by zlite
Sat Nov 03, 2018 10:13 pm
Forum: FAQ
Topic: Latency
Replies: 3
Views: 1744

Re: Latency

I have the same problem, even with the API. Moderators: any suggestions?
by zlite
Thu Aug 09, 2018 1:32 am
Forum: FAQ
Topic: Manual setting of X,Y axis
Replies: 6
Views: 6222

Re: Manual setting of X,Y axis

Is the version of the dashboard that fixes this going to be available soon? It's now been broken since March
by zlite
Sun Jul 29, 2018 10:48 pm
Forum: FAQ
Topic: Updates stop when hedgehog is plugged in via USB (SOLVED)
Replies: 1
Views: 1455

Updates stop when hedgehog is plugged in via USB (SOLVED)

I had a weird situation with a hedgehog connected to a RaspberryPi via USB. When it was stand-alone, it updated its position as usual. But when I plugged it into the RPi via USB, it stopped updating. With the help of the Marvelmind tech support, we figured out what was going on. The hedgehog and mod...
by zlite
Mon Mar 12, 2018 3:11 am
Forum: FAQ
Topic: Marvelmind instructions no longer working with latest ArduRover?
Replies: 7
Views: 3647

Re: Marvelmind instructions no longer working with latest ArduRover?

I eventually got this working. Many of the instructions were wrong, but here are some tips: Use GPS_Type 5 (not 0) Use EKF 2 (not 3) Make sure you match all the settings on both the Marvelmind and Pixhawk side: GPS refresh rate (8Hz), baud rate of Serial ports (I used 115k) and serial type (GPS). My...

Go to advanced search